интернет в гостевом Wi-fi

Wi-fi и всё с ним связанное
Аватара пользователя
Chupaka
Сообщения: 3315
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: интернет в гостевом Wi-fi

Сообщение Chupaka »

Добрый. Дайте деталей же :)
Аватара пользователя
b1gst0ne
Сообщения: 17
Зарегистрирован: 30 янв 2018, 02:13

Re: интернет в гостевом Wi-fi

Сообщение b1gst0ne »

Настраивал на дефолтной конфигурации
из вайфай сети test интернета нет (я понимаю, что и не будет ибо не настроено)
в бридже инет есть

Код: Выделить всё

# model = RouterBOARD 952Ui-5ac2nD
/interface bridge
add admin-mac=64:D1:55:77:A4:6C auto-mac=no comment=defconf name=bridge
add name=bridgeWLAN
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    disabled=no distance=indoors frequency=auto installation=indoor mode=\
    ap-bridge ssid=JF wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=99999999
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=test \
    supplicant-identity="" wpa2-pre-shared-key=test1234
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
    20/40/80mhz-XXXX country=russia disabled=no distance=indoors frequency=\
    auto installation=indoor mode=ap-bridge security-profile=test ssid=TEST \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/ip pool
add name=pool_wifi ranges=192.168.99.100-192.168.99.200
/ip dhcp-server
add address-pool=pool_wifi disabled=no interface=bridgeWLAN name=dhcp_wifi
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridgeWLAN comment=defconf interface=wlan2
add bridge=bridge interface=ether1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf disabled=yes interface=ether1 list=WAN
/ip address
add address=192.168.99.1/24 comment=defconf interface=bridgeWLAN network=\
    192.168.99.0
add address=192.168.1.4 interface=bridge network=192.168.1.4
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.99.0/24 comment=defconf dns-server=192.168.99.1,8.8.8.8 \
    gateway=192.168.99.1
/ip dns
set allow-remote-requests=yes servers=192.168.1.1
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip route
add distance=1 gateway=bridge
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system identity
set name=Office
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Аватара пользователя
b1gst0ne
Сообщения: 17
Зарегистрирован: 30 янв 2018, 02:13

Re: интернет в гостевом Wi-fi

Сообщение b1gst0ne »

Просмотрел пару последних тем почти в каждой вопрос про интернет из изолированной WiFi сети в интернет через микротик который работает как свич. Может есть адекватные мануалы для подобной задачи чтоб людей сразу туда направлять?
Аватара пользователя
Chupaka
Сообщения: 3315
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: интернет в гостевом Wi-fi

Сообщение Chupaka »

Ну, поскольку в деталях отсутствуют как диагностика, так и чёткое определение того, что значит в данном случае "интернета нет" - могу предположить загвоздку с DNS. Добавьте bridgeWLAN в интерфейс-лист LAN для проверки, что ли. Если нет - сделайте трассировку с клиента сети test на ya.ru и 8.8.8.8

З.Ы. Что за микротик работает как свитч - не понял. Вроде роутер у вас, а не свитч...
Аватара пользователя
b1gst0ne
Сообщения: 17
Зарегистрирован: 30 янв 2018, 02:13

Re: интернет в гостевом Wi-fi

Сообщение b1gst0ne »

Chupaka писал(а): 19 сен 2021, 22:54 Что за микротик работает как свитч - не понял. Вроде роутер у вас, а не свитч...
Полноценный роутер выполняет простую функцию свитча на эзернет портах, но так как это полноценный роутер с вай-фаем то хочется использовать его чуть сложней чем просто свитч
Chupaka писал(а): 19 сен 2021, 22:54 что значит в данном случае "интернета нет"
из bridgeWLAN нет интернтета
Chupaka писал(а): 19 сен 2021, 22:54 Добавьте bridgeWLAN в интерфейс-лист LAN для проверки
не помогло
Chupaka писал(а): 19 сен 2021, 22:54 Если нет - сделайте трассировку с клиента сети test на ya.ru и 8.8.8.8
дальше 192.168.99.1(этот микторик) трассировка не уходит

это таблица маршрутизации в микротике

Код: Выделить всё

/ip route print
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          bridge                    1
 1 ADC  192.168.1.4/32     192.168.1.4     bridge                    0
 2 ADC  192.168.99.0/24    192.168.99.1    bridgeWLAN                0
Аватара пользователя
Chupaka
Сообщения: 3315
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: интернет в гостевом Wi-fi

Сообщение Chupaka »

Chupaka писал(а): 19 сен 2021, 22:54 что значит "интернета нет"
b1gst0ne писал(а): 20 сен 2021, 02:52 нет интернтета
Если переставить слова местами - сильно понятнее от этого не становится :)
b1gst0ne писал(а): 20 сен 2021, 02:52 это таблица маршрутизации в микротике

Код: Выделить всё

/ip route print
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          bridge                    1
 1 ADC  192.168.1.4/32     192.168.1.4     bridge                    0
 2 ADC  192.168.99.0/24    192.168.99.1    bridgeWLAN                0
Какой-то у вас непонятный шлюз по умолчанию... Подозреваю, из-за этого и проблема. Как доступ в Интернет осуществляется? Вряд ли весь Интернет у вас доступен на интерфейсе bridge...