Проблема DHCP

Базовая функциональность RouterOS
studentvitek
Сообщения: 3
Зарегистрирован: 03 июн 2022, 09:22

Проблема DHCP

Сообщение studentvitek »

Добрый день. Помогите, подскажите куда смотреть. Есть два DHCP на двух Bridge, первый (name=dhcp_local_0) со статической привязкой по MAC, который выдает известным устройствам адрес и второй динамический для неизвестных. Но периодически устройства из статики получают IP из динамики. В чем может быть проблема? Комутаторы по сети менял, кабеля тоже, сетевые вроде не глючат.


/ip dhcp-server
add add-arp=yes disabled=no interface=local_0 lease-time=2h name=dhcp_local_0
add add-arp=yes address-pool=pool_local_all authoritative=after-10sec-delay \
disabled=no interface=local_all lease-time=2m name=dhcp_all
/ip pool
add name=pool_local_all ranges=172.16.16.10-172.16.16.250
/ip dhcp-server network
add address=172.16.16.0/24 dns-server=172.16.16.254 gateway=172.16.16.254
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
Аватара пользователя
Chupaka
Сообщения: 3483
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Проблема DHCP

Сообщение Chupaka »

Добрый. Покажите же, кто что получает, почему вы думаете, что так не должно быть, и что при этом в логе.

Т.е. вы хотите сказать, что устройства, подключенные к интерфейсу local_0, неожиданно получают адрес от сервера, принимающего запросы на интерфейсе local_all? Поделитесь схемой сети.
studentvitek
Сообщения: 3
Зарегистрирован: 03 июн 2022, 09:22

Re: Проблема DHCP

Сообщение studentvitek »

Подсети физически и виртуально в сети не отделены. Порт интерфейса local_0 и Порт интерфейса local_all подключены к неуправляемому коммутатору к которому подключены и все устройства.
Аватара пользователя
Chupaka
Сообщения: 3483
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Проблема DHCP

Сообщение Chupaka »

Ну вот и ответ. Зачем такие сложности? Сделайте всё через один интерфейс и один DHCP-сервер. Если при запросе адреса сервер находит подходящую статическую запись - он использует данные из неё. Если не находит - выдаёт адрес из address-pool.
studentvitek
Сообщения: 3
Зарегистрирован: 03 июн 2022, 09:22

Re: Проблема DHCP

Сообщение studentvitek »

Да. Перемудрил я. Все просто работает. Спасибо за совет.