Шейпер видео сервисов и блокировка

Базовая функциональность RouterOS
bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Шейпер видео сервисов и блокировка

Сообщение bassz »

Подскажите как зарезать скорость на youtube и запрещать тоже чтото не получается
пробовал для блокирования
/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube).*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=youtube new-connection-mark=BLOCK_connection_youtube passthrough=yes
add action=mark-packet chain=prerouting connection-mark=BLOCK_connection_youtube new-packet-mark=BLOCK_youtube_packet

/ip firewall filter
add action=drop chain=forward packet-mark=BLOCK_youtube_packet
add action=drop chain=input packet-mark=BLOCK_youtube_packet
правило блокирует tut.by для ютуба не работает
/ip firewall filter
add action=reject chain=forward content=ithelp21.ru protocol=tcp reject-with=tcp-reset
хочется найти хороший способ блокировки и резать скорость на онлайн видео сервисах

Аватара пользователя
Sir_Prikol
Сообщения: 308
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: Шейпер видео сервисов и блокировка

Сообщение Sir_Prikol »

Используйте адресс-лист, там теперь можно по доменным именам, Layer7 слишком хорошо кушает процессор
Дома: RB4011 (6-ISP(GPON)белый IP)

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka »

Вы маркируете соединение на 53 порт UDP, это DNS-запросы, и их потом дропаете. Это не совсем то, что вы описываете. Ловить надо по protocol=tcp any-port=443, видимо. Ну и я бы заменил prerouting на forward.

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz »

придумал резать скорость
метим трафик prerouting по content yotube.com направляем в адрес лист list_yorube
потом
метим forward list_yorube new packet mark packet_yorube
и режем скорость в simple Queues

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz »

не очень вариант тот что выше ( в адрес листы попадает много чего нужного кроме ютуба )
нужно как то найти способ метить трафик онлайн видео

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka »

Сложность в том, что:

а) трафик зашифрован;
б) данные идут с серверов, которые обслуживают и другие сервисы Гугла.

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz »

может по объему трафика ? с серверов гугла скорость шейпить

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka »

По объёму — это параметр connection-bytes