Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Базовая функциональность RouterOS
Ответить
Anvar
Сообщения: 2
Зарегистрирован: 17 июл 2019, 14:57

Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Сообщение Anvar » 17 июл 2019, 15:25

Привет ребята, помогите пожалуйста разобраться.

У меня пул белых ip. В принципе все работает кроме NAT 1:1, мне надо серому ip приклеить публичный. За маскарадингом cерые в инет ходят как положено.


Немного о конфигурации микротика
На внешнем интерфейсе прописаны белые адреса 66.64.28.2/26 по 66.64.28.62/26 в настройках интерфейса ARP - Enabled
Интерфейс во внутреннюю сеть 10.77.77.1/24
Гейт к провайдеру 66.64.28.1
Получилось привязать 1 из белых ip к своему компу - белый 66.64.28.26 к серому 10.77.77.26
Когда я создаю еще 2 правила srcnat и dnat, для следующего ip инет у него не работает. В правиле dnat ноль пакетов, хотя первые два работают как часы будто я не за NAT.
Например хочу добавить 66.64.28.29 к 10.77.77.29 и тишина. Пробовал просто не добавляя новые правила подставить .29 к рабочим правилам, вместо .26 просто .29 менял и нифига...

из 61 адреса работают частично 57 . 55 итд перебиал все 61 половина не работает. Ума не приложу почему так



Настройки natmap

masquerade (серые ip, которые не в адрес лист -netmap_ip) ходят через обычный маскарадинг.

/ip firewall nat add action=masquerade chain=srcnat src-address-list=!netmap_ip disabled=no out-interface=ether5


Netmap

/ip firewall nat add chain=srcnat src-address=10.77.77.26 action=netmap to-addresses=66.64.28.26

/ip firewall nat add chain=dstnat dst-address=66.64.28.26 action=netmap to-addresses=10.77.77.26


Добавление ip В адрес лист

/ip firewall address-list add list="netmap_ip" address=10.77.77.26

midius
Сообщения: 14
Зарегистрирован: 05 июн 2019, 13:10

Re: Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Сообщение midius » 17 июл 2019, 16:52

Anvar писал(а):
17 июл 2019, 15:25

/ip firewall nat add chain=srcnat src-address=10.77.77.26 action=netmap to-addresses=66.64.28.26
Попробуй так.
/ip firewall nat add chain=srcnat src-address=10.77.77.26 action=src-nat to-addresses=66.64.28.26

Аватара пользователя
Chupaka
Сообщения: 2085
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Сообщение Chupaka » 17 июл 2019, 19:15

Masquerade в самом верху у вас? А если вниз передвинуть?

Anvar
Сообщения: 2
Зарегистрирован: 17 июл 2019, 14:57

Re: Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Сообщение Anvar » 19 июл 2019, 15:48

Chupaka писал(а):
17 июл 2019, 19:15
Masquerade в самом верху у вас? А если вниз передвинуть?
Здравсвуйте, да маскарад в самом низу

Аватара пользователя
Chupaka
Сообщения: 2085
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Не работает NAT 1:1 (netmap правила) проброс публичного ip к серому.

Сообщение Chupaka » 19 июл 2019, 17:37

Сдаётся мне, что не в правилах NAT у вас проблема, а в приёме пакетов на эти адреса. Через Tools -> Torch посмотрите на внешний интерфейс: приходят ли к вам пакеты, которые вы хотите DST-NAT'ом ловить?

Ответить