BGP анонс 2 подсетей

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
Sir_Prikol
Сообщения: 389
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

BGP анонс 2 подсетей

Сообщение Sir_Prikol »

Доброго времени суток

Имеем следующую проблему
анонсирую сеть на другой рутер. Пока идёт анонс одной подсети - проблем нет, как только добавляю вторую сеть для анонса - она не вылетает. Анонсится только первая сеть. Голову сломал о причине
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Chupaka
Сообщения: 3030
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: BGP анонс 2 подсетей

Сообщение Chupaka »

Доброго.

Художественное описание своими словами - это, конечно, хорошо...

А можно узнать, что именно делалось на роутере? Включена ли синхронизация у добавляемой для анонса Network? Есть ли маршрут к ней в IP Routes? Не зафильтрован ли анонс в Routing Filters?
Аватара пользователя
Sir_Prikol
Сообщения: 389
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: BGP анонс 2 подсетей

Сообщение Sir_Prikol »

Ну художественный стиль - это вообще прекрасно. :) А по теме, (я разобрался и сделал, но просто оставлю это для потомков)...

Имеем на головном рутере фильтр богон сетей на discard. На клиентском анонсим сеть (к примеру) 192.168.115.0/24, не смотря на фильтр - она прилетает, добавляем у клиента вторую сеть на анонс - она не прилетает. Убираем фильтры - прилетают обе. Осталось понять что за глюк, что одна из сетей прилетает в любом случае

Клиент

Код: Выделить всё

/routing bgp instance
set default as=65001 client-to-client-reflection=no
/routing bgp network
add network=192.168.100.0/24 synchronize=no
/routing bgp peer
add hold-time=1m in-filter=unblock keepalive-time=10s name=peer1 remote-address=100.64.0.1 remote-as=65000 ttl=default
/routing filter
add action=accept chain=unblock set-in-nexthop-direct=Unblock


Головной

Код: Выделить всё

/routing bgp instance
add as=65000 name=to.bras redistribute-other-bgp=yes router-id=192.0.2.1
........



/routing bgp peer
add hold-time=1m in-filter=from-bras-bgp-in instance=to.bras name=to.bras.01 out-filter=to-bras-bgp-out remote-address=100.64.50.1 remote-as=65001 ttl=default
/routing filter
add action=discard chain=from-bras-bgp-in comment="BRAS (bgp in)" prefix=0.0.0.0/8 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=10.0.0.0/8 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=100.64.0.0/10 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=127.0.0.0/8 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=169.254.0.0/16 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=172.16.0.0/12 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=192.0.0.0/24 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=192.0.2.0/24 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=192.88.99.0/24 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=192.168.0.0/16 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=198.18.0.0/15 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=198.51.100.0/24 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=203.0.113.0/24 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=224.0.0.0/4 prefix-length=0-32
add action=discard chain=from-bras-bgp-in prefix=240.0.0.0/4 prefix-length=0-32
add action=discard chain=from-bras-bgp-in protocol=bgp
add action=discard chain=to-bras-bgp-out comment="BRAS (bgp out)" prefix=0.0.0.0/8 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=10.0.0.0/8 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=100.64.0.0/10 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=127.0.0.0/8 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=169.254.0.0/16 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=172.16.0.0/12 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=192.0.0.0/24 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=192.0.2.0/24 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=192.88.99.0/24 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=192.168.0.0/16 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=198.18.0.0/15 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=198.51.100.0/24 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=203.0.113.0/24 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=224.0.0.0/4 prefix-length=0-32
add action=discard chain=to-bras-bgp-out prefix=240.0.0.0/4 prefix-length=0-32
add action=accept bgp-communities=64999:1 chain=to-bras-bgp-out comment="\D0\E0\E7\F0\E5\F8\B8\ED\ED\EE\E5 \EA\EE\EC\FC\FE\ED\E8\F2\E8 (64999:1)"
add action=discard chain=to-bras-bgp-out comment="\C7\E0\EF\F0\E5\F2 \E2\F1\E5\E3\EE \EE\F1\F2\E0\EB\FC\ED\EE\E3\EE" protocol=bgp
add action=discard chain=to-bras-bgp-out comment="================================================================" disabled=yes protocol=bgp


Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Sir_Prikol
Сообщения: 389
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: BGP анонс 2 подсетей

Сообщение Sir_Prikol »

В общем сам разобрался, чтобы летели все сети, надо рисовать фильтры на клиенте с нужными сетями на out и экшеном access, что не есть логично. Как только используется входящий фильтр у пира - то надо создавать и исходящией, если нет входящего фильтра у пира - то анонсится всё что прописано в networks и фильтры рисовать не надо
Дома: CCR2004 (7-ISP(GPON)белый IP)